l/libffado: Move ffado-mixer-qt3 to ffado-mixer if Qt4 version

is not built.
slackware-14.2
Damien Goutte-Gattat 13 years ago
parent 8c6b267bdc
commit d710d4bbc3
  1. 11
      l/libffado/libffado.SlackBuild

@ -25,7 +25,9 @@
# Latest libffado sourcecode is available at: <http://www.ffado.org/>.
#
# Depends: d/scons, gnome/libxml++, l/libiec61883
# Suggests: l/pyqt
# Optional: l/pyqt
#
# Note: PyQt is only needed at runtime by the GUI mixer ffado-mixer.
# Source package infos
NAMESRC=${NAMESRC:-libffado}
@ -36,7 +38,7 @@ WGET=${WGET:-http://www.ffado.org/files/$ARCHIVE}
# Build infos
NAMETGZ=${NAMETGZ:-libffado}
PKGVERSION=${PKGVERSION:-2.0rc2}
BUILD=${BUILD:-1GGD}
BUILD=${BUILD:-2GGD}
ARCH=${ARCH:-i486}
JOBS=${JOBS:-1}
@ -93,6 +95,11 @@ scons install DESTDIR=$PKG
find $PKG | xargs file | grep "ELF 32-bit LSB" | cut -d : -f 1 | \
xargs strip --strip-unneeded 2> /dev/null
# If only ffado-mixer-qt3 has been built, rename it to ffado-mixer
if [ ! -f $PKG/usr/bin/ffado-mixer ]; then
mv $PKG/usr/bin/ffado-mixer-qt3 $PKG/usr/bin/ffado-mixer
fi
# Install the documentation
mkdir -p $PKG/usr/doc/$NAME
install -m 644 \

Loading…
Cancel
Save