Browse Source

l/python-pexpect: Upgraded to python-pexpect-4.7.0.

current-20191101
Damien Goutte-Gattat 2 years ago
parent
commit
afc4eb951e
  1. 1
      l/python-pexpect/pexpect-4.4.0.tar.gz.sha256
  2. 1
      l/python-pexpect/pexpect-4.7.0.tar.gz.sha256
  3. 19
      l/python-pexpect/python-pexpect.SlackBuild

1
l/python-pexpect/pexpect-4.4.0.tar.gz.sha256

@ -1 +0,0 @@
67b85a1565968e3d5b5e7c9283caddc90c3947a2625bed1905be27bd5a03e47d pexpect-4.4.0.tar.gz

1
l/python-pexpect/pexpect-4.7.0.tar.gz.sha256

@ -0,0 +1 @@
9e2c1fd0e6ee3a49b28f95d4b33bc389c89b20af6a1255906e90ff1262ce62eb pexpect-4.7.0.tar.gz

19
l/python-pexpect/python-pexpect.SlackBuild

@ -1,6 +1,6 @@
#!/bin/bash
# Build script for Slackware
# Copyright (C) 2018 Damien Goutte-Gattat
# Copyright (C) 2018,2019 Damien Goutte-Gattat
#
# Redistribution and use of this script, with or without modifications,
# is permitted provided that the following conditions are met:
@ -29,9 +29,8 @@
# Source package infos
NAMESRC=${NAMESRC:-pexpect}
VERSION=${VERSION:-4.4.0}
VERSION=${VERSION:-4.7.0}
ARCHIVE=${ARCHIVE:-$NAMESRC-$VERSION.tar.gz}
WGET=${WGET:-https://pypi.python.org/packages/fa/c3/60c0cbf96f242d0b47a82e9ca634dcd6dcb043832cf05e17540812e1c707/$ARCHIVE}
# Build infos
NAMEPKG=${NAMEPKG:-python-pexpect}
@ -60,8 +59,7 @@ fi
# Get and verify the source archive
if [ ! -r $ARCHIVE ]; then
wget -c -O $ARCHIVE.part "$WGET"
mv $ARCHIVE.part $ARCHIVE
pip3 download --no-binary :all: --no-deps $NAMESRC==$VERSION
fi
sha256sum -c $ARCHIVE.sha256
NAME=$(tar ft $ARCHIVE | head -n 1 | cut -d / -f 1)
@ -71,13 +69,10 @@ cd $TMP
echo "Building $ARCHIVE..."
tar xf $CWD/$ARCHIVE
cd $NAME
python setup.py build
# This will produce a syntax error when byte-compiling;
# the error is to be ignored as the module that cannot be
# byte-compiled is only intended to be used by Python3.
# Upstream thinks it is fine:
# <https://github.com/pexpect/pexpect/issues/290>.
python setup.py install --root=$PKG
python2 setup.py build
python2 setup.py install --root=$PKG
python3 setup.py build
python3 setup.py install --root=$PKG
# Install the documentation
mkdir -p $PKG/usr/doc/$NAMEPKG-$VERSION

Loading…
Cancel
Save