Browse Source

l/zope.component: Upgraded to zope.component-4.6.

current-20191101
Damien Goutte-Gattat 2 years ago
parent
commit
a5e045841d
  1. 1
      l/zope.component/zope.component-4.4.1.tar.gz.sha256
  2. 1
      l/zope.component/zope.component-4.6.tar.gz.sha256
  3. 19
      l/zope.component/zope.component.SlackBuild

1
l/zope.component/zope.component-4.4.1.tar.gz.sha256

@ -1 +0,0 @@
1b29aa65413f6dda29e64e2352a6aa13d9ba70078f6b91f328573488788d531c zope.component-4.4.1.tar.gz

1
l/zope.component/zope.component-4.6.tar.gz.sha256

@ -0,0 +1 @@
ec2afc5bbe611dcace98bb39822c122d44743d635dafc7315b9aef25097db9e6 zope.component-4.6.tar.gz

19
l/zope.component/zope.component.SlackBuild

@ -1,6 +1,6 @@
#!/bin/bash
# Build script for Slackware
# Copyright (C) 2018 Damien Goutte-Gattat
# Copyright (C) 2018,2019 Damien Goutte-Gattat
#
# Redistribution and use of this script, with or without modifications,
# is permitted provided that the following conditions are met:
@ -25,13 +25,14 @@
# Latest zope.component sourcecode is available at:
# <https://github.com/zopefoundation/zope.component>.
#
# Depends: l/zope.event
# Depends: l/zope.deferredimport, l/zope.deprecation, l/zope.event
# Depends: l/zope.hookable, l/zope.interface
# Source package infos
NAMESRC=${NAMESRC:-zope.component}
VERSION=${VERSION:-4.4.1}
VERSION=${VERSION:-4.6}
ARCHIVE=${ARCHIVE:-$NAMESRC-$VERSION.tar.gz}
WGET=${WGET:-https://pypi.python.org/packages/45/3c/bd34f228e2ff303071b5ff68657abf6d11af2151056acd449796eff694e0/$ARCHIVE}
WGET=${WGET:-https://files.pythonhosted.org/packages/32/97/81ce1c228e8a7e98ef92e8ff211b091cf5a223d6d69cb599368798084042/$ARCHIVE}
# Build infos
NAMEPKG=${NAMEPKG:-zope.component}
@ -71,8 +72,10 @@ cd $TMP
echo "Building $ARCHIVE..."
tar xf $CWD/$ARCHIVE
cd $NAME
python setup.py build
python setup.py install --root=$PKG
python2 setup.py build
python2 setup.py install --root=$PKG
python3 setup.py build
python3 setup.py install --root=$PKG
# Install the documentation
mkdir -p $PKG/usr/doc/$NAME
@ -84,7 +87,11 @@ install -D -m 644 $CWD/slack-desc $PKG/install/slack-desc
# Add dependency infos
cat <<EOF > $PKG/install/slack-required
zope.deferredimport
zope.deprecation
zope.event
zope.hookable
zope.interface
EOF
# Package the tree

Loading…
Cancel
Save