Browse Source

l/PyQt5: Upgraded to PyQt5-5.9.2.

slackware-14.2
Damien Goutte-Gattat 3 years ago
parent
commit
58dd4735f3
  1. 10
      l/PyQt5/PyQt5.SlackBuild
  2. 1
      l/PyQt5/PyQt5_gpl-5.7.tar.gz.sha256
  3. 1
      l/PyQt5/PyQt5_gpl-5.9.2.tar.gz.sha256

10
l/PyQt5/PyQt5.SlackBuild

@ -1,6 +1,6 @@
#!/bin/bash
# Build script for Slackware
# Copyright (C) 2017 Damien Goutte-Gattat
# Copyright (C) 2017,2019 Damien Goutte-Gattat
#
# Redistribution and use of this script, with or without modifications,
# is permitted provided that the following conditions are met:
@ -25,11 +25,11 @@
# Latest PyQt5 sourcecode is available at:
# <https://riverbankcomputing.com/software/pyqt/intro/>.
#
# Depends: l/qt5-webkit
# Depends: l/python-enum34, l/python2-sip, l/qt5-webkit
# Source package infos
NAMESRC=${NAMESRC:-PyQt5}
VERSION=${VERSION:-5.7}
VERSION=${VERSION:-5.9.2}
ARCHIVE=${ARCHIVE:-${NAMESRC}_gpl-$VERSION.tar.gz}
WGET=${WGET:-http://downloads.sourceforge.net/pyqt/$ARCHIVE}
@ -91,6 +91,8 @@ CXXFLAGS=$CPUOPT \
python configure.py \
--confirm-license \
--verbose \
--sip=/usr/bin/python2-sip \
--sip-incdir=/usr/include/python2.7/python2-sip \
--qmake /usr/bin/qmake-qt5
make -j $JOBS
make install INSTALL_ROOT=$PKG
@ -108,6 +110,8 @@ install -D -m 644 $CWD/slack-desc $PKG/install/slack-desc
# Add dependency infos
cat <<EOF > $PKG/install/slack-required
python-enum34
python2-sip
qt5-webkit
EOF

1
l/PyQt5/PyQt5_gpl-5.7.tar.gz.sha256

@ -1 +0,0 @@
892693ba5f79989abb2061dad2d5c4e6f127e9dd3240f73f8220c7152cd35b05 PyQt5_gpl-5.7.tar.gz

1
l/PyQt5/PyQt5_gpl-5.9.2.tar.gz.sha256

@ -0,0 +1 @@
c190dac598c97b0113ca5e7a37c71c623f02d1d713088addfacac4acfa4b8394 PyQt5_gpl-5.9.2.tar.gz
Loading…
Cancel
Save