l/python-llvmlite: Added python-llvmlite-0.15.0.
parent
0bd4138d16
commit
3b1bf92776
@ -0,0 +1,11 @@
|
||||
diff -Naur llvmlite-0.15.0.orig/ffi/build.py llvmlite-0.15.0/ffi/build.py
|
||||
--- llvmlite-0.15.0.orig/ffi/build.py 2016-08-15 17:32:45.000000000 +0100
|
||||
+++ llvmlite-0.15.0/ffi/build.py 2018-05-02 20:54:01.631650226 +0100
|
||||
@@ -124,6 +124,7 @@
|
||||
os.environ['LLVM_LIBS'] = ' '.join(libs.split())
|
||||
|
||||
cxxflags = run_llvm_config(llvm_config, ["--cxxflags"])
|
||||
+ cxxflags = cxxflags.replace('-Wcovered-switch-default', '')
|
||||
cxxflags = cxxflags.split() + ['-fno-rtti', '-g']
|
||||
os.environ['LLVM_CXXFLAGS'] = ' '.join(cxxflags)
|
||||
|
@ -0,0 +1 @@
|
||||
c855835537eda61f3a0d19aedc44f006d5084a2d322aee8ffa87aa06bb800dc4 llvmlite-0.15.0.tar.gz
|
@ -0,0 +1,98 @@
|
||||
#!/bin/bash
|
||||
# Build script for Slackware
|
||||
# Copyright (C) 2018 Damien Goutte-Gattat
|
||||
#
|
||||
# Redistribution and use of this script, with or without modifications,
|
||||
# is permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR AS IS'' AND ANY EXPRESS OR
|
||||
# IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
|
||||
# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
|
||||
# DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT,
|
||||
# INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
|
||||
# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
|
||||
# SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
|
||||
# HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
|
||||
# STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
|
||||
# IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
|
||||
# POSSIBILITY OF SUCH DAMAGE.
|
||||
#
|
||||
# Contact: Damien Goutte-Gattat <dgouttegattat@incenp.org>
|
||||
#
|
||||
# Latest llvmlite sourcecode is available at:
|
||||
# <http://llvmlite.pydata.org/>.
|
||||
#
|
||||
# Note: llvmlite-0.15.0 is the last version to work with LLVM 3.8.0.
|
||||
|
||||
# Source package infos
|
||||
NAMESRC=${NAMESRC:-llvmlite}
|
||||
VERSION=${VERSION:-0.15.0}
|
||||
ARCHIVE=${ARCHIVE:-$NAMESRC-$VERSION.tar.gz}
|
||||
WGET=${WGET:-https://files.pythonhosted.org/packages/5a/61/bee4cfb45fe57007ad907c818c7be1a976a1de3df1e51c0c4bd9d139cfa6/$ARCHIVE}
|
||||
|
||||
# Build infos
|
||||
NAMEPKG=${NAMEPKG:-python-llvmlite}
|
||||
BUILD=${BUILD:-1GGD}
|
||||
ARCH=${ARCH:-$(uname -m | sed 's/^i.86$/i486/;s/^arm.*/arm/')}
|
||||
JOBS=${JOBS:-1}
|
||||
EXT=${EXT:-txz}
|
||||
|
||||
# Directories
|
||||
TMP=${TMP:-/tmp}
|
||||
OUT=${OUT:-$TMP/build}
|
||||
PKG=${PKG:-$OUT/$NAMEPKG}
|
||||
CWD=$(pwd)
|
||||
|
||||
set -e # Quit if a command returns non-zero
|
||||
|
||||
# Sanity checks
|
||||
if [ $UID -eq 0 ]; then
|
||||
echo "You should NOT run this script as ROOT!"
|
||||
exit 1
|
||||
fi
|
||||
if [ ! -d $TMP ]; then
|
||||
echo "$TMP does not exists or is not a directory!"
|
||||
exit 1
|
||||
fi
|
||||
|
||||
# Get and verify the source archive
|
||||
if [ ! -r $ARCHIVE ]; then
|
||||
wget -c -O $ARCHIVE.part "$WGET"
|
||||
mv $ARCHIVE.part $ARCHIVE
|
||||
fi
|
||||
sha256sum -c $ARCHIVE.sha256
|
||||
NAME=$(tar ft $ARCHIVE | head -n 1 | cut -d / -f 1)
|
||||
|
||||
# Compile
|
||||
cd $TMP
|
||||
echo "Building $ARCHIVE..."
|
||||
tar xf $CWD/$ARCHIVE
|
||||
cd $NAME
|
||||
patch -p1 < $CWD/llvmlite-0.15.0-cxxflags.patch
|
||||
python setup.py build
|
||||
python setup.py install --root=$PKG
|
||||
|
||||
# Install the documentation
|
||||
mkdir -p $PKG/usr/doc/$NAMEPKG-$VERSION
|
||||
install -m 644 LICENSE README.rst $PKG/usr/doc/$NAMEPKG-$VERSION
|
||||
|
||||
# Copy slack-desc file
|
||||
install -D -m 644 $CWD/slack-desc $PKG/install/slack-desc
|
||||
|
||||
# Package the tree
|
||||
cd $PKG
|
||||
mkdir -p $OUT
|
||||
PACKAGING="
|
||||
chown root:root . -R
|
||||
/sbin/makepkg -l y -c n $OUT/$NAMEPKG-$VERSION-$ARCH-$BUILD.$EXT
|
||||
rm -rf $PKG
|
||||
rm -rf $TMP/$NAME
|
||||
"
|
||||
if type -p fakeroot ; then
|
||||
echo "$PACKAGING" | fakeroot
|
||||
else
|
||||
su -c "$PACKAGING"
|
||||
fi
|
@ -0,0 +1,12 @@
|
||||
|-----handy-ruler-----------------------------------------------------|
|
||||
python-llvmlite: python-llvmlite (Python LLVM wrapper)
|
||||
python-llvmlite:
|
||||
python-llvmlite: This package provides a lightweight wrapper around basic LLVM
|
||||
python-llvmlite: functionality.
|
||||
python-llvmlite:
|
||||
python-llvmlite:
|
||||
python-llvmlite:
|
||||
python-llvmlite:
|
||||
python-llvmlite:
|
||||
python-llvmlite:
|
||||
python-llvmlite:
|
Loading…
Reference in New Issue