Browse Source

l/vtk: Downgraded to vtk-6.3.0.

slackware-14.2
Damien Goutte-Gattat 3 years ago
parent
commit
295f785c08
  1. 1
      l/vtk/VTK-6.3.0.tar.gz.sha256
  2. 1
      l/vtk/VTK-8.1.1.tar.gz.sha256
  3. 10
      l/vtk/vtk.SlackBuild

1
l/vtk/VTK-6.3.0.tar.gz.sha256

@ -0,0 +1 @@
92a493354c5fa66bea73b5fc014154af5d9f3f6cee8d20a826f4cd5d4b0e8a5e VTK-6.3.0.tar.gz

1
l/vtk/VTK-8.1.1.tar.gz.sha256

@ -1 +0,0 @@
71a09b4340f0a9c58559fe946dc745ab68a866cf20636a41d97b6046cb736324 VTK-8.1.1.tar.gz

10
l/vtk/vtk.SlackBuild

@ -28,9 +28,9 @@
# Source package infos
NAMESRC=${NAMESRC:-VTK}
VERSION=${VERSION:-8.1.1}
VERSION=${VERSION:-6.3.0}
ARCHIVE=${ARCHIVE:-$NAMESRC-$VERSION.tar.gz}
WGET=${WGET:-https://www.vtk.org/files/release/8.1/$ARCHIVE}
WGET=${WGET:-https://www.vtk.org/files/release/6.3/$ARCHIVE}
# Build infos
NAMEPKG=${NAMEPKG:-vtk}
@ -94,7 +94,7 @@ cmake \
-DVTK_INSTALL_LIBRARY_DIR=lib$LIBDIRSUFFIX \
-DVTK_INSTALL_ARCHIVE_DIR=lib$LIBDIRSUFFIX \
-DVTK_INSTALL_DOC_DIR=doc/$NAMEPKG-$VERSION \
-DVTK_INSTALL_PACKAGE_DIR=lib$LIBDIRSUFFIX/cmake/vtk-8.1 \
-DVTK_INSTALL_PACKAGE_DIR=lib$LIBDIRSUFFIX/cmake/vtk-6.3 \
-DVTK_INSTALL_PYTHON_MODULE_DIR=lib$LIBDIRSUFFIX/python2.7/site-packages \
-DVTK_INSTALL_QT_PLUGIN_DIR=lib$LIBDIRSUFFIX/qt5/plugins/designer \
-DVTK_WRAP_PYTHON=ON \
@ -109,6 +109,10 @@ cmake \
make
make install/strip DESTDIR=$PKG
# Fix bogus installation of Qt Designer plugin (WTF?)
mv $PKG$TMP/$NAME/build/lib$LIBDIRSUFFIX/qt5 $PKG/usr/lib$LIBDIRSUFFIX/qt5
rm -rf $PKG$TMP
# Install the documentation
install -m 644 ../CONTRIBUTING.md ../README.md $PKG/usr/doc/$NAMEPKG-$VERSION

Loading…
Cancel
Save