Browse Source

n/gnupg: Upgraded to gnupg-2.2.18.

current-20191101
Damien Goutte-Gattat 2 years ago
parent
commit
075d17f0b3
  1. 1
      n/gnupg/gnupg-2.2.17.tar.bz2.sha256
  2. 1
      n/gnupg/gnupg-2.2.18.tar.bz2.sha256
  3. 14
      n/gnupg/gnupg.SlackBuild

1
n/gnupg/gnupg-2.2.17.tar.bz2.sha256

@ -1 +0,0 @@
afa262868e39b651a2db4c071fba90415154243e83a830ca00516f9a807fd514 gnupg-2.2.17.tar.bz2

1
n/gnupg/gnupg-2.2.18.tar.bz2.sha256

@ -0,0 +1 @@
30d37ce2ca55b2b9b61480b2a175a3b22066ab41cd3f84688448919b566dec0a gnupg-2.2.18.tar.bz2

14
n/gnupg/gnupg.SlackBuild

@ -24,11 +24,13 @@
#
# Latest gnupg sourcecode is available at: <https://www.gnupg.org/>.
#
# Depends: l/npth, l/libgcrypt, l/libassuan, l/libksba
# Note: As of 25 November 2019, the following dependencies are
# all provided by Slackware-current in their latest versions:
# l/npth, l/libgcrypt, l/libassuan, l/libksba.
# Source package infos
NAMESRC=${NAMESRC:-gnupg}
VERSION=${VERSION:-2.2.17}
VERSION=${VERSION:-2.2.18}
PKGVERSION=${VERSION/-beta/b}
ARCHIVE=${ARCHIVE:-$NAMESRC-$VERSION.tar.bz2}
WGET=${WGET:-https://gnupg.org/ftp/gcrypt/gnupg/$ARCHIVE}
@ -118,14 +120,6 @@ install -m 644 AUTHORS COPYING COPYING.* ChangeLog NEWS README THANKS \
# Copy slack-desc file
install -D -m 644 $CWD/slack-desc $PKG/install/slack-desc
# Add dependency infos
cat <<EOF > $PKG/install/slack-required
libassuan
libgcrypt
libksba
npth
EOF
# Package the tree
cd $PKG
mkdir -p $OUT

Loading…
Cancel
Save